1. 안드로이드의 경우
    • 안드로이드는 기본적으로 블루투스 V3.0까지 지원하는 SPP (시리얼포트프로파일)을 공식 지원합니다. 따라서 칩센에서 판매하고 있는 SPP지원용 블루투스 모듈/시리얼 제품군은 모두 사용이 가능합니다.
    • 안드로이드에서 BLE(bt4.0이상 이하 BLE)제품을 사용하려고 하면 안드로이드 버젼 v4.3 이상에서만 지원을 합니다. 만약 안드로이드폰이 BLE 서버로서 동작을 시키고자 하신다면 안드로이드 버전 v5.0을 지원해야 합니다. 통상 삼성 갤럭시폰의 기준으로 갤럭시 S3부터 BLE를 지원합니다.
  2. 아이폰의 경우
    • 아이폰 또는 IOS의 경우 애플에서 SPP를 공식 지원하고 있지 않습니다. 따라서 SPP지원용 블루투스 v3.0 이하의 제품은 아이폰에서 사용할 수 없습니다.
    • 만약 SPP를 꼭 필요로 하는 경우에는 애플의 MFI인증을 받아야 하며 제품에 애플의 인증칩이 내장되어야 하며 관련 프로토콜 펌웨어가 지원되어야 합니다.
    • BLE제품은 IOS와의 통신에 제약사항은 없습니다. iPhone 4S이상에서 BLE를 지원합니다.
  3. 윈도우 OS의 경우
    • 윈도우는 마이크로소프트 내장 블루투스 스택의 경우 SPP제품을 연결 시 가상 블루투스 시리얼포트를 장치관리자에서 만들어 줍니다. 따라서 시리얼 포트 관련 프로그래밍만을 통해 쉽게 접근이 가능할 수 있습니다.
    • 윈도우에서 BLE를 사용하려면 마이크로소프트에서 윈도우8 이상의 버전에서 API를 제공하고 있습니다. 따라서 윈도우 7에서는 사용이 불가능 합니다.